Page tree

Unsupported Release

This documentation relates to DSpace 1.8.x, an old, unsupported version. Looking for another version? See all documentation.

As of January 2015, DSpace 1.8.x is no longer supported. We recommend upgrading to a more recent version of DSpace. See DSpace Software Support Policy.

Skip to end of metadata
Go to start of metadata

In the notes below [dspace] refers to the install directory for your existing DSpace installation, and [dspace-1.2.2-source] to the source directory for DSpace 1.2.2. Whenever you see these path references, be sure to replace them with the actual path names on your local system.

Upgrade Steps

The changes in 1.2.2 are only code and config changes so the update should be fairly simple.

  1. Get the new DSpace 1.2.2 source code from the DSpace page on SourceForge and unpack it somewhere. Do not unpack it on top of your existing installation!!
  2. Copy the PostgreSQL driver JAR to the source tree. For example:
    cd  [dspace]/lib
    cp postgresql.jar  [dspace-1.2.2-source]/lib
    
  3. Take down Tomcat (or whichever servlet container you're using).
  4. Your 'localized' JSPs (those in jsp/local) now need to be maintained in the source directory. If you have locally modified JSPs in your [dspace]/jsp/local directory, you might like to merge the changes in the new 1.2.2 versions into your locally modified ones. You can use the diff command to compare the 1.2.1 and 1.2.2 versions to do this. Also see the version history for a list of modified JSPs.
  5. You need to add a new parameter to your [dspace]/dspace.cfg for configurable fulltext indexing
    ##### Fulltext Indexing settings #####
    # Maximum number of terms indexed for a single field in Lucene.
    # Default is 10,000 words - often not enough for full-text indexing.
    # If you change this, you'll need to re-index for the change
    # to take effect on previously added items.
    # -1 = unlimited (Integer.MAX_VALUE)
    search.maxfieldlength = 10000
    
  6. In [dspace-1.2.2-source] run:
    ant -Dconfig= [dspace]/config/dspace.cfg update
    
  7. Copy the .war Web application files in [dspace-1.2.2-source]/build to the webapps sub-directory of your servlet container (e.g. Tomcat). e.g.:
    cp  [dspace-1.2.2-source]/build/*.war
    	[tomcat]/webapps
    
    If you're using Tomcat, you need to delete the directories corresponding to the old .war files. For example, if dspace.war is installed in [tomcat]/webapps/dspace.war, you should delete the [tomcat]/webapps/dspace directory. Otherwise, Tomcat will continue to use the old code in that directory.
  8. To finalize the install of the new configurable submission forms you need to copy the file [dspace-1.2.2-source]/config/input-forms.xml into [dspace]/config.
  9. Restart Tomcat.
  • No labels