All Versions


DSpace Documentation


Page tree

Old Release

This documentation relates to an old version of DSpace, version 3.x. Looking for another version? See all documentation.

Skip to end of metadata
Go to start of metadata

In the notes below [dspace] refers to the install directory for your existing DSpace installation, and [dspace-1.4.x-source] to the source directory for DSpace 1.4.x. Whenever you see these path references, be sure to replace them with the actual path names on your local system.

Upgrade Steps

The changes in 1.4.x releases are only code and configuration changes so the update is simply a matter of rebuilding the wars and slight changes to your config file.

  1. Get the new DSpace 1.4.x source code from the DSpace page on SourceForge and unpack it somewhere. Do not unpack it on top of your existing installation!!
  2. Copy the PostgreSQL driver JAR to the source tree. For example:

    cd [dspace]/lib
    cp postgresql.jar [dspace-1.4.x-source]/lib

  3. Note: Licensing conditions for the handle.jar file have changed. As a result, the latest version of the handle.jar file is not included in this distribution. It is recommended you read the [new license conditions|http://www.handle.net/upgrade_6-2_DSpace.html] and decide whether you wish to update your installation's handle.jar. If you decide to update, you should replace the existing handle.jar in [dspace-1.4.x-source]/lib with the new version.
  4. Take down Tomcat (or whichever servlet container you're using).
  5. A new configuration item webui.html.max-depth-guess has been added to avoid infinite URL spaces. Add the following to the dspace.cfg file:

    #### Multi-file HTML document/site settings #####
    #
    # When serving up composite HTML items, how deep can the request be for us to
    # serve up a file with the same name?
    #
    # e.g. if we receive a request for "foo/bar/index.html"
    # and we have a bitstream called just "index.html"
    # we will serve up that bitstream for the request if webui.html.max-depth-guess
    # is 2 or greater. If webui.html.max-depth-guess is 1 or less, we would not
    # serve that bitstream, as the depth of the file is greater.
    #
    # If webui.html.max-depth-guess is zero, the request filename and path must
    # always exactly match the bitstream name. Default value is 3.
    #
    webui.html.max-depth-guess = 3

    If webui.html.max-depth-guess is not present in dspace.cfg the default value is used. If archiving entire web sites or deeply nested HTML documents it is advisable to change the default to a higher value more suitable for these types of materials.
  6. Your 'localized' JSPs (those in jsp/local) now need to be maintained in the source directory. If you have locally modified JSPs in your [dspace]/jsp/local directory, you will need to merge the changes in the new 1.4.x versions into your locally modified ones. You can use the diff command to compare your JSPs against the 1.4.x versions to do this. You can also check against the DSpace CVS.
  7. In [dspace-1.4.x-source] run:

    ant -Dconfig= [dspace]/config/dspace.cfg update

  8. Copy the .war Web application files in [dspace-1.4.x-source]/build to the webapps sub-directory of your servlet container (e.g. Tomcat). e.g.:

    cp [dspace-1.4.x-source]/build/*.war [tomcat]/webapps

    If you're using Tomcat, you need to delete the directories corresponding to the old .war files. For example, if dspace.war is installed in [tomcat]/webapps/dspace.war, you should delete the [tomcat]/webapps/dspace directory. Otherwise, Tomcat will continue to use the old code in that directory.
  9. Restart Tomcat.
  • No labels