
IDE Integration - DSpace, Eclipse and Tomcat
July 19, 2010:  If you are using Eclipse with DSpace for development, please These instructions are out-of-date, confusing and need a full review.
help us to simplify and clarify these instructions. Please, work with the new page at .DSpace IDE - Eclipse, Git, Maven, and Tomcat
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Eclipse Tools: Prerequisite Installation

Eclipse (required)

Obviously, to do this you will need to have Eclipse Installed: http://www.eclipse.org/

This HOW-TO has been written using , but it is also known to work in Eclipse 3.3 as well. The information here probably works Eclipse 3.4 (Ganymede)
with other versions of Eclipse, but no guarantees are made.

We need to install a variety of plugins to allow us to interact with DSpace and Tomcat in a fully integrated way. To install plugins into Eclipse you should 
use: Help -> Software Updates

On this page you will find a couple of pre-set install sites. For the plugins that we need we also need to add some new sites to this list (see next section), 
which is done by clicking on the " " tab, and clicking " " on the right.Available Software Add Site..

After you have installed all of these plugins, or in-between each one, you will need to restart the Eclipse workspace

Install the SVN Plugin

Subversion (SVN) enables you to checkout the DSpace source code and keep up-to-date with the latest changes to the platform from DSpace Repository.

Eclipse >= 3.5:

In Eclipse select "Help --> Install New Software...". 

https://wiki.lyrasis.org/display/DSPACE/DSpace+IDE+-+Eclipse%2C+Git%2C+Maven%2C+and+Tomcat
http://www.eclipse.org/


In the drop down list select "Helios - ."http://download.eclipse.org/release/helios

From the list select "Collaboration --> Subversive SVN Team Provider"

http://download.eclipse.org/release/helios


Click the "Next >" button and follow the dialogs to install the plugins.

Restart Eclipse.

Eclipse ask you which Subversive Connector you want to use. Choose SVN Kit or JavaHL.

Eclipse < 3.5:

There are 2 popular SVN plugins for Eclipse. You only need to install  of them:one

SubVersive Install Instructions: http://www.eclipse.org/subversive/downloads.php

SubClipse Install Instructions: http://subclipse.tigris.org/install.html

You should install the most recent version of your preferred client. The recommendation is SubVersive (as it is an Eclipse Incubation project), and the 
remainder of this tutorial assumes that this is the one you are using.

28th July 2007: This is an additional commentary on the current situation. As of version 1.1.3, Subversive uses the JavaHL bindings for the default 
Subversion client (this is the same as Subclipse). Whilst largely positive, this is not without it's side effects. Firstly, most of the unique functionality of 
Subversive will not work with JavaHL (it only works with JavaSVN, which is not only no longer the default, it's effectively deprecated). Secondly, the 
'compare with' functionality does not work for folders, only individual files. For these reasons, it may be better for now to use Subclipse - which shares 
much of the same functionality, and the 'compare with' feature does work with folders (when using the JavaHL bindings). If you are thinking of switching to 
Subclipse from Subversive, then one thing you may find is that the labelling of new and changed files is not as clear as it was with Subversive. This can be 
rectified by going into preferences dialog, and under Team -> SVN -> Label Decorations, select the Text tab. Then set 'Label decoration for outgoing' to '>' 
and 'Label decoration for added' to '*' - this will effectively replicate Subversive's labelling.

Note: also that if you are using a plugin with the 'JavaHL' bindings, you will need to have the Subversion command line client installed and available on 
your path, and the JavaHL shared libraries installed and either ensure that the LD_LIBRARY_PATH environment variable is set to include the directory 
containing the JavaHL libraries, or that you include that path in a -Djava.library.path= definition in your eclipse.ini.

SysDeo Tomcat Plugin (optional)

If you'd like to run Tomcat directly within Eclipse, and do some basic debugging, you may find it useful to install this Tomcat Plugin.

Install the most recent version of the plugin, which is available for download from:

http://www.eclipsetotale.com/tomcatPlugin.html

Unfortunately, there is no remote URL location for the sysdeo plugin. You will have to manually download the plugin and unzip it into the [eclipse]/plug
 directory. Also, you will need to have Tomcat installed locally. Obtain the latest version of Tomcat from: ins http://jakarta.apache.org/tomcat

Maven 2 Plugin (required for DSpace 1.5)

You only need to install Maven if you are using DSpace 1.5 or later.

http://www.eclipse.org/subversive/downloads.php
http://subclipse.tigris.org/install.html
http://www.eclipsetotale.com/tomcatPlugin.html
http://jakarta.apache.org/tomcat
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Prerequisite: Before installing the Maven 2 Plugin for Eclipse, you  install Apache Maven from must http://maven.apache.org/

Install the most recent version of the plugin using the below remote URL.

Remote URL: http://m2eclipse.sonatype.org/update/

The remote URL for the m2eclipse project has moved to: http://m2eclipse.sonatype.org/sites/m2e

Web Standard Tools (optional)

These are tools for convenience in using Eclipse with web application projects such as DSpace. They are not required for having DSpace and Eclipse 
integrated, although they are useful

For Eclipse 3.2.2
This uses a pre-configured plugin site. Go to:  and select the checkbox on the Callisto Discovery Site -> Web & J2EE Development -> Web Standard Tools
left. This will alert you to required dependencies. Click " " on the right and this will resolve those dependencies.Select Required

For Eclipse 3.3
This uses a pre-configured plugin site. Go to: _Web Tools Platform (WTP) Updates -> Web Tools Platform (WTP) -> Web Standard Tools (WST) Project _ 
and select the checkbox on the left.

Database Tools (optional)

These are tools for convenience in using Eclipse with web application projects such as DSpace. They are not required for having DSpace and Eclipse 
integrated, although they are useful

For Eclipse 3.2.2
This also uses the pre-configured plugin site. Go to:  and select the checkbox on the left (this will also Callisto Discovery Site -> Database Development
select all the packages underneath that directory). Click " " to resolve the dependencies before installingSelect Required

For Eclipse 3.3
This also uses the pre-configured plugin site. Go to "Europa Discovery Site -> Database Development '' and select the checkbox on the left selecting all 
the packages underneath that directory.

Configuring your working environment
Obviously it's really up to you how you want your Eclipse to look, but this section details how to configure the tomcat plugin in general, and which views 
you will find useful to have included in your main Java Perspective.

Code Formatting

Download the DSpace's Coding Conventions config file: dspace-eclipse-format.xml|IDE Integration - DSpace, Eclipse and Tomcat^dspace-
Install either as workspace default or for your individual DSpace eclipse-format.xml|||^Dspace-eclipse-format.xml|^Dspace-eclipse-format.xml|\

project(s).
#*  Select  in Eclipse. Go to the . Click the " " button and (Workspace Default) Window -> Preferences Java -> Code Style -> Formatter Import...
select the file.

(Individual Project) Right click on the DSpace project, select . Go to the . Click the " " Properties Java -> Code Style -> Formatter Import...
button and select the file.

Preparing the Tomcat Plugin

Open the Tomcat preferences pane: Window -> Preferences -> Tomcat
Select your installed Tomcat version, and its home page (hit  when finished). For example:Apply

Tomcat Version: 6.x
Tomcat Home: /opt/tomcat6

Under , enter the Tomcat Base (hit  when finished). This should generally be the same as the Tomcat Home:Tomcat -> Advanced Apply
Tomcat Base: /opt/tomcat6

Under , you need to enter the JDK's  file for the " ". You should find Tomcat -> JVM Settings tools.jar Classpath (before generated classpath)
this in the directory   If you are using Mac OS X, the  library does not exist on the [installed jdk]/lib/tools.jar Note: tools.jar
platform. Instead using  found at: classes.jar /System/Library/Frameworks/JavaVM.framework/Versions/${JAVA_VERSION}
/Classes/classes.jar
Under , enter a username and password for the desired manager user. If this user doesn't already exist hit "Tomcat -> Tomcat Manager App Add 

" (hit  when finished)user to tomcat-users.xml Apply

Visual Configuration of Eclipse

To add a new View to the current Perspective, use:  (in general). From here you can select the view to open from a list of Window -> Show View -> Other
available categories.

Add the Console View ( )General -> Console

http://maven.apache.org/
http://m2eclipse.sonatype.org/update/
http://m2eclipse.sonatype.org/sites/m2e
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Add the Database Explorer View ( )Data -> Database Exporer
Activate line numbering:  and select " "Window -> Preferences -> General -> Editors -> Text Editors Show line numbers

Setting up the remote SVN target

Open the SVN Repository Exploring Perspective by using Window -> Open Perspective -> Other -> SVN Repository Exploring
Right click in the "SVN Repository" View on the left, and use: New -> Repository Location
Enter the location of the DSpace SVN repository: https://dspace.svn.sourceforge.net/svnroot/dspace

"Access restriction: The type DataSource is not accessible due to restriction on required library 
<jre_path>/lib/rt.jar"

For some reason, Eclipse is configured by default to forbid direct use of some types which are defined in the JRE. There are a lot of new restrictions on 
version 1.6 of the JRE and this is one of them. You can find lots of queries and lots of advice about this on the Web, mostly to the effect that you can 
disable the error. It may be better, however, to take the rarer advice and rearrange the build path for an affected project:

On the Project menu, select Properties.
In the resulting dialog, select the Java Build Path category, then its Order and Export tab.
Select JRE System Library and move it below Maven Dependencies.

Working with DSpace 1.4.x
(If you are working with DSpace 1.5 see the  section after this)Working with DSpace 1.5

NEEDS UPDATING – Not sure this actually works! [15 Apr 2008]

Checking out DSpace as a Tomcat Project

Open up the location with the arrow on the left, and drill down to find trunk/dspace
Right click on trunk/dspace and select "Find/Checkout as..."; leave "Check out as a project configured using the New Project Wizard" selected 
and hit "Finish".
You will be given a list of project types to check out as. Select  and hit " "Java -> Tomcat Project Next
Insert a name for the project. For example . Then hit " ".dspace-svn Next
Leave the context name as-is (this is the url path that dspace will become available under), and leave " " checked. In can update context definition
the box marked " " enter "/jsp". Then hit " ".Subdirectory to set as application root Finish
Follow the on-screen instructions, and see the source code get checked out into your eclipse workspace. You should now have a new project 
called , which will contain some additional things to the contents of the SVN repository, including now a directory named " ", and dspace-svn work
two files:  and .cvsignore .tomcatplugin
Configure the fine details of this Tomcat Project by right clicking on the project name and selecting Properties -> Java Build Path

Java Build Path -> Source: " " on the right, and select the "src" directory in the root of the project (you may notice your project Add Folder
being compiled in the background)
Java Build Path -> Source: select the folder  and hit " " on the rightdspace-svn/jsp/WEB-INF/src Remove
Java Build Path -> Libraries: " " on the right, and select all of the files in  and hit " ". This tells Eclipse to use Add JARs dspace-svn/lib OK
these as part of your classpath, and your deployed application.

Now we have DSpace set up as a tomcat project, although it won't work yet until we've installed DSpace into the Eclipse Workspace ...

Installing DSpace 1.4.x into the Eclipse Workspace

Preparation for install

This section is principally the same as the standard DSpace installation, so assumes that you are familiar with that process, and doesn't dwell on potential 
difficulties.

Obtain the PostgreSQL JDBC driver, and drop it into dspace-svn/lib
Create a directory dspace-svn/jsp/WEB-INF/lib
Copy all of the jar files from  into dspace-svn/lib dspace-svn/jsp/WEB-INF/lib
Open up the project Preferences, and go to , and use " " to add the new JAR file for postgresPreferences -> Java Build Path -> Libraries Add JARs
create a directory under  into which you want to install the application. For example dspace-svn dspace-svn/working-copy
copy  into  with the file name dspace-svn/config/dspace.cfg dspace-svn/working-copy dspace.cfg.initial
Prepare the configuration for installation in the Eclipse Workspace. The configuration does not need to be heavily modified, but the following 
points should be set correctly:

The installation path you give should be:

  dspace.dir = <workspace>/dspace/working-copy

where <workspace> is the absolute path to your Eclipse workspace, and "working-copy" is the name of the directory into which we will install the DSpace 
application. Other configuration that you should ensure are set correctly are as follows (assuming installation on the local machine):

https://dspace.svn.sourceforge.net/svnroot/dspace
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  # DSpace base URL.  Include port number etc., but NOT trailing slash
  dspace.url = http://localhost:8080/dspace-svn

  # DSpace host name - should match base URL.  Do not include port number
  dspace.hostname = localhost

  # Name of the site
  dspace.name = DSpace 1.4.x in Eclipse

Using Ant to install DSpace 1.4.x

Now we can perform the install inside the Eclipse workspace. To keep everything nice and eclipse-centric, we will build it inside Eclipse using Ant. 
Right click on the  file, and select  (note that there are two Ant Build options, and you want the second one, with the build.xml Run As -> Ant Build...
trailing dots)
Targets Tag: uncheck "compile" and check "fresh_install"
Main Tag: In the Arguments box, insert -Dconfig=/home/user/workspace/dspace-svn/dspace-install/dspace.cfg.initial
Hit "Apply" at the bottom of the page, to save the build configuration
Hit " " at the bottom of the page. If you have the Console view open you will see Ant building the DSpace application inside Eclipse. This will Run
produce the usual output of a DSpace fresh_install. If you right click your project and hit " " you will see the changes it has made to your Refresh
workspace. There will be a new directory called  which will contain the compiled classes, the built WAR files, and the  and build dspace-web.xml oai

 files. Unfortunately, this method of working with DSpace will only support the main DSpace application (you can adapt this methodology -web.xml
to work with OAI in a different Tomcat Project). Your " " directory will also contain the fully installed application, including the working-copy
assetstore, logs and so forth, which is very useful.
Open the directory  and copy the file  into  with the name .dspace-svn/build dspace-web.xml dspace-svn/jsp/WEB-INF web.xml
Open the directory  and copy the file  into dspace-svn/build/classes Messages.properties dspace-svn/jsp/WEB-INF/classes

SVN Ignore

The following resources will be needed to be set to SVN Ignore, to ensure that unwanted resources are not committed to the repository:

.cvsignore

.tomcatproject
build/
jsp/local
jsp/WEB-INF/lib
jsp/WEB-INF/web.xml
work
working-copy

To set these to be ignored, right click on the resource and go:  then select " "Team -> Add to svn:ignore Resource(s) by name

Viewing the application in a web browser

With the stages above complete you can now start tomcat and view the DSpace application in a web browser.

(Re)start the Tomcat web server through the Eclipse interface. This is done by clicking the right-most of the three tomcat buttons that are in the Eclipse 
toolbar courtesy of the SysDeo plugin. (In normal operation, you can restart the context without restarting tomcat, which can be done by right clicking on 
the project name and selecting Tomcat project -> Reload this context; furthermore, Eclipse will regularly auto-deploy the context while you are making 
changes). You can see the results of these actions reflected in the Console View if you have it open.

You should now find the DSpace deployed; try the following URL to see if it is working correctly:

http://localhost:8080/dspace-svn

Note that due to the limitations of the 1.4.x source structure, it is only possible to view one web application at a time from the same project when deployed 
within Eclipse. To work on the web interface and the OAI interface simultaneously you must use DSpace 1.5 and follow the instructions below. Otherwise, 
it is possible to modify this HOW-TO so that the OAI interface is deployed in Tomcat rather than the usual web interface.

Working with DSpace 1.5

Brief intro to DSpace 1.5 modules

DSpace 1.5 consists of several "modules", which better separate out the underlying DSpace API from the various user interfaces or web services available 
with DSpace. These modules are as follows (  some modules have sub-modules!):Note:

dspace - The root module, which builds all of DSpace and holds the DSpace configurations

http://localhost:8080/dspace-svn
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dspace-api - The DSpace API module, which contains all the primary business logic (Java code)
dspace-jspui - The JSP-based User Interface for DSpace
dspace-xmlui - The XML-based User Interface for DSpace (also known as )Manakin

dspace-xmlui-api - The primary API for the XML-UI for DSpace (including all Aspect Java code)
dspace-xmlui-wing - The Digital Repository Interface (DRI) API for XML-UI
dspace-xmlui-webapp - The XML-UI web application configurations (including all Aspect & Theme definitions)

dspace-oai - The  interface for DSpaceOAI-PMH
dspace-lni - The  for DSpaceLightweight Network Interface (LNI)

dspace-lni-core - The primary API for LNI
dspace-lni-client - The client API for LNI (along with a simple sample client)
dspace-lni-webapp - The LNI web application configurations

dspace-sword - The SWORD [interface for DSpace
dspace-sword-api - The SWORD API
dspace-sword-webapp - The SWORD web application

language-packs - The Internalization (I18N) language packs for DSpace (  Currently JSP-UI only - the I18N for Manakin is in the dspace-
 )xmlui-webapp module

pom.xml - The Maven module, which contains the primary Maven configurations to build DSpace

Checking out the projects

Because DSpace 1.5 consists of many "modules" (see above), it lends itself to being worked with as several separate Eclipse projects! However, you do 
have some choice in how you want to work with DSpace 1.5 in Eclipse. Overall, there seems to be three main options (feel free to add more if you have 

):other ideas

The One-Big-Project Approach (  - easiest to setup)RECOMMENDED
Advantage(s): Only a single project in your Eclipse workspace. Can perform debugging through Eclipse Tomcat Plugin (but only for ONE 
user interface). Can have multiple DSpace 1.5.x versions running side-by-side in one Eclipse Workspace.
Disadvantage(s): Can only debug ONE user interface at a time. This is a limitation of the Eclipse Tomcat Plugin, which only allows you to 
define a single Tomcat 'context' per Eclipse project. Slower build times since you are compiling all of the DSpace modules from source.

The One-Project-Per-Module Approach ( )A little more complex to setup, but allows more flexibility
Advantage(s): Can use the Eclipse Tomcat Plugin for debugging, and debug multiple interfaces at the same time (e.g. JSPUI side-by-
side with XMLUI, OAI-PMH and/or LNI)
Disadvantage(s): Since each Eclipse project  be named the same as the corresponding DSpace module, you*cannot* have two must
DSpace 1.5.x (or above) versions running side-by-side in the same Eclipse Workspace.

The Combined Approach (  Need to verify if this route still works - 27 Mar 2008)More difficult to setup.
Advantage(s): Can use the Eclipse Tomcat Plugin for debugging. Tries to combine the above two approaches to allow you to have differe

 of modules checked out as separate projects in Eclipse. It also allows you to simultaneously debug multiple user interfaces nt versions
(XML-UI, JSP-UI, OAI-PMH, and/or LNI) in Eclipse via the Tomcat Plugin.
Disadvantage(s): It's definitely a little "messy" as far as Eclipse is concerned, since you will have several Eclipse projects within a 
primary project (and Eclipse favors a "flat" structure for its Projects). In addition, you must checkout and work with DSpace 1.5 code into 
a location  under your normal Eclipse workspace.not

The One-Big-Project Approach
Eclipse no longer supports the "Enable Nested Modules" option described below. See: https://issues.sonatype.org/browse/MNGECLIPSE-2291

This is the simplest approach and therefore is  for any new/novice developers. This approach allows you to checkout DSpace 1.5 as highly recommended
a single Eclipse Project. However, it  allows you to define a single user interface to debug tools using the Eclipse Tomcat plugin.only

Select  in EclipseFile -> New... -> Project
Select  and click "Next"SVN -> Projects from SVN
Select to " " and choose the DSpace SourceForge repository ( )Use an existing repository https://dspace.svn.sourceforge.net/svnroot/dspace
Select the version of DSpace you want to checkout, likely either under " " (e.g. ) or " " (e.g. tags tags -> dspace-1_5 branches branches -> dspace-

). Click "Next"1_5_x
Choose " ". Give it a name (e.g. ), and click "Finish". Eclipse will then checkout the Check Out as Project with the name specified dspace-1_5_x
DSpace 1.5 source code from SVN.
Return to the " " in Eclipse (" "). You should see your newly created project in the Java Perspective Window -> Open Perspective -> Java Package 

.Explorer
Right-Click on your project and select " ". Eclipse will now read the Maven  configuration file Maven -> Enable Dependency Management pom.xml
and auto-configure your project as a " "!Java Project
Right-Click again, and select " ". This tells Maven Eclipse plugin that your project contains several nested sub-Maven -> Enable Nested Modules
modules within it.
Right-Click one last time, and select " " (" " for Eclipse 3.2.0). Eclipse will now Maven -> Update Source Folders Maven -> Download Sources
automatically locate all the DSpace Java source code, as well as all the 3rd party JAR dependencies.

You now have a complete copy of DSpace 1.5 source code! Jump directly to the section on how to .Build and Install DSpace

The One-Project-Per-Module Approach

This approach allows you to utilize the debugging tools available with the Eclipse Tomcat plugin, and treat your projects in a more "Maven-friendly" 
fashion. However, it will require you to create separate projects for each DSpace module.

Checkout each DSpace module as a separate Eclipse project, one-by-one, similar to the following:

Open the SVN Repository Exploring Perspective by using Window -> Open Perspective -> Other -> SVN Repository Exploring
Open up the location of the DSpace SVN repository with the arrow on the left, and drill down to select the version of DSpace you want to 
checkout, likely either under " " (e.g. ) or " " (e.g. ).tags tags -> dspace-1_5 branches branches -> dspace-1_5_x

https://wiki.lyrasis.org/display/DSPACE/Manakin
http://www.openarchives.org/OAI/openarchivesprotocol.html
https://wiki.lyrasis.org/display/DSPACE/LightweightNetworkInterface
https://issues.sonatype.org/browse/MNGECLIPSE-2291
https://dspace.svn.sourceforge.net/svnroot/dspace
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Choose the DSpace modules you wish to work with (for a description of the available modules see the  above). Brief intro to DSpace 1.5 modules
You do  need to checkout all of the DSpace modules, but the following modules are  for DSpace to build properly:not required

dspace - the primary module, which builds/configures DSpace
dspace-api - the DSpace API module

Select the DSpace modules you wish to checkout, Right-click and choose " ". Eclipse will checkout each DSpace module as a separate Check Out
project, and give the project the same name as the module (e.g.  module will be in an Eclipse project named " ").dspace-xmlui dspace-xmlui
Return to the " " in Eclipse. You should see a project created for each DSpace module.Java Perspective
Select  of these new projects, Right-Click and select " ". Eclipse will now read the Maven  all Maven -> Enable Dependency Management pom.xml
configuration file under each of these projects, and auto-configure each project as a " "!Java Project
Select  of these projects , Right-Click and select " ". Eclipse will now automatically download all the 3rd all again Maven -> Update Source Folders
party JAR dependencies for each of these projects!

Hints/Tips:

Because of the number of DSpace 1.5 projects, you may want to change your Eclipse Package Explorer to display your projects as "Working 
Sets". This allows you to group similar projects together within a virtual "folder" in Eclipse.

Click on the downward arrow in your "Package Explorer"
Select "Configure Working Sets"
Create a "New" working set and name it "DSpace 1.5" (or similar). Select all your DSpace 1.5 projects as its "contents"
Ensure it is set to "visible" by placing a checkmark next to your new Working Set. Click "Ok" to save.
Go back to the downward arrow in your "Package Explorer", and select "Top Level Elements -> Working Sets". Your Eclipse should now 
show a "DSpace 1.5" folder, which contains all your DSpace projects.

The Combined Approach

This approach attempts to combine the best of both of the above approaches. It allows you to utilize the debugging tools available with the Eclipse Tomcat 
plugin. It also allows you to potentially run two versions of DSpace 1.5.x side-by-side in the same Eclipse workspace (see  at end of this Hints/Tips
section). The disadvantage is that it is a little "messy", and requires that you checkout DSpace 1.5 to a location  in your normal Eclipse workspace.not

First, we will checkout DSpace 1.5 from SVN.   You must perform the checkout into a location that is not under your Eclipse workspace 
. Therefore, if you perform an SVN checkout using Eclipse, you  move that folder to another location  you can proceed.folder must before

(e.g.)   svn co https://dspace.svn.sourceforge.net/svnroot/dspace/branches/dspace-1_5_x dspace-1_5_x-src
NOTE: Make sure that you checkout DSpace 1.5 to a "stable" location (i.e. not to a temporary directory like ). During the next step /tmp
(when you will import the DSpace modules into Eclipse), Eclipse will  copy the code into your Eclipse workspace. Rather, it will just not
reference the location where you have checked out DSpace 1.5 via SVN...so, this location will (in a sense) become your DSpace 1.5 
"workspace".
ADDITIONAL NOTE: This requirement to checkout DSpace 1.5 to a folder not in your Eclipse workspace unfortunately seems to be a 
limitation of the  Maven plugin for Eclipse. If you attempt to re-import Maven projects which already exist in your Eclipse m2eclipse
workspace, you will end up with a bunch of empty project folders.

Next, we will point Eclipse at the location where you checked out DSpace 1.5 to, and tell Eclipse to import it as a series of Maven Projects
Select  in EclipseFile -> Import
Select  as the type of source. Click "Next".General -> Maven Projects
Browse to the location where you just checked out DSpace 1.5
Eclipse will automatically parse out all the various Maven projects which are located there (based on the location of the Maven  pom.xml
file in each DSpace module). It will display a list of all DSpace modules & sub-modules, and allow you to check which ones you wish to 
import. If you don't want to import all the modules at this time, you can always go back and repeat this same process to checkout 
additional modules.
It is*highly recommended to  select the top-level , since this is the module which builds DSpace.always pom.xml
It is also*recommended to uncheck any sub-modules of  or  (e.g.  is a submodule dspace-xmlui dspace-lni dspace-xmlui-api
of ). This will decrease the number of separate DSpace projects in your Eclipse workspace.dspace-xmlui

You may choose to uncheck any DSpace modules you are not planning on working with. For example, if you don't want to work 
with the , then uncheck all of its modules ( , , , DSpace LNI dspace-lni dspace-lni-core dspace-lni-client dspace-

). As mentioned, you can always repeat this process to import the DSpace LNI code if you need to, afterall. lni-webapp
After you have selected the DSpace modules you wish to work with, click "Next". Eclipse will now create the number of DSpace projects 
you selected, and auto-identify those projects which contain Java code as . It will also locate all the 3rd party JAR Java Projects
dependencies for each project and add them automatically to your project's classpath.

You should now have separate Eclipse projects for your various DSpace modules.  You'll notice that Eclipse did  move this code Important: not
into your normal Eclipse workspace. Rather, Eclipse is just referencing those folders whereever you originally checked them out via SVN.

Notes:

What you've done in this Combined Approach is basically "trick" Eclipse into allowing you to have projects within projects. In addition, Eclipse has 
not created folders in the normal workspace for any of this DSpace 1.5 code. Rather, it is just referencing the code in the location where you first 
checked it out via SVN.
Because you have "tricked" it, Eclipse may not always refresh your DSpace 1.5 projects properly after a rebuild/update. This is easily fixed by 
manually selecting all the projects, Right-clicking and choosing " "Refresh

Hints/Tips:

If you want, you can run  side-by-side in your Eclipse workspace.multiple versions of DSpace 1.5.x (or above)
To do so, you first must rename*all* of your existing DSpace 1.5.x projects (since Eclipse doesn't allow two projects of the same name). 
Right click on the project and select " ". Don't worry, this will  change the names of the folders on your filesystem Refactor -> Rename not
(so Maven will still work perfectly).

e.g. Rename  project to  (for the 1.5alpha version of this project).dspace-api dspace-api-1.5alpha
After renaming all of your existing DSpace 1.5.x projects, you can follow the directions for the  again to The Combined Approach
successfully checkout & import a different version of DSpace 1.5.x into the same Eclipse workspace.

Because of the number of DSpace 1.5 projects, you may want to change your Eclipse Package Explorer to display your projects as "Working 
Sets". This allows you to group similar projects together within a virtual "folder" in Eclipse.

https://dspace.svn.sourceforge.net/svnroot/dspace/branches/dspace-1_5_x
https://wiki.lyrasis.org/display/DSPACE/LightweightNetworkInterface
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Click on the downward arrow in your "Package Explorer"
Select "Configure Working Sets"
Create a "New" working set and name it "DSpace 1.5" (or similar). Select all your DSpace 1.5 projects as its "contents"
Ensure it is set to "visible" by placing a checkmark next to your new Working Set. Click "Ok" to save.
Go back to the downward arrow in your "Package Explorer", and select "Top Level Elements -> Working Sets". Your Eclipse should now 
show a "DSpace 1.5" folder, which contains all your DSpace projects.

Build and Install DSpace

Defining Maven Tasks in Eclipse

The Maven build tool will compile all the relevant parts of the DSpace application so that we can work on it in the correct environment.

Note: If you look closely, you'll notice that each project directory has its own pom.xml file. This file contains the instructions to the Maven build system 
which tell it what to assemble for that DSpace module. The pom.xml file in the  project directory contain primary Maven instructions, and dspace
references  of the other pom.xml files.all

To ease building/cleaning your DSpace projects, it's highly recommended to create some quick "tasks" within Eclipse's " ". To get to External Tools Dialog
the , look in the Eclipse toolbar for the Green "play" (>) button with a Red toolbox under it. Click on it, and select "External Tools Dialog Open External 

".Tools Dialog

DSpace Clean task (Cleans all of DSpace)
Right click on " " section and select "New"Maven Build
Name it something like "DSpace Clean"
Click the "Browse Workspace" button, and select your  sub-module (or separate project).dspace
In the , enter "clean", click Apply.Goals

DSpace Assemble task (Assembles all of DSpace)
Right click on " " section and select "New"Maven Build
Name it something like "DSpace Assemble"
Click the "Browse Workspace" button, and select your  sub-module (or separate project).dspace
In the , enter "package", click Apply.Goals

JSPUI Assemble task (Assembles  the JSP-UI - useful if you only changed the JSP-UI)just
Right click on " " section and select "New"Maven Build
Name it something like "JSPUI Assemble"
Click the "Browse Workspace" button, and select your  sub-module (or separate project).dspace-jspui
In the , enter "package", click Apply.Goals

XMLUI Assemble task (Assembles  the XML-UI - useful if you only changed the XML-UI)just
Right click on " " section and select "New"Maven Build
Name it something like "XMLUI Assemble"
Click the "Browse Workspace" button, and select your  sub-module (or separate project).dspace-xmlui
In the , enter "package", click Apply.Goals

You can also create tasks to assemble  the OAI-PMH interface ( ) or LNI ( ) similar to those for the XMLUI and just dspace-oai dspace-lni
JSPUI.

After creating these tasks, you may want to add them to your "Favorites", so that they appear in your  dropdown. Click back on the External Tools Dialog Ext
 button, and choose " ". Then, add all of your tasks to your favorites!ernal Tools Dialog Add to Favorites

Running Maven to Build DSpace

Just run your  task, as detailed in the  section above.DSpace Assemble Defining Maven Tasks in Eclipse

If you are looking at the Console view in Eclipse, you will know the build has been successful when you see it terminate with a message similar to the 
following:

[INFO] ----------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL org.dspace:dspace:pom:1.5-SNAPSHOT (  task-segment: [package] )
[INFO] ----------------------------------------------------------------------------
[INFO] Total time: 32 second
[INFO] Finished at: Tue Nov 27 14:17:56 CST 2007
[INFO] Memory 8M/63M
[INFO] ----------------------------------------------------------------------------

You will need to select your DSpace 1.5 Eclipse project(s), Right Click, and select "Refresh" to see the changes that this makes to each of the 
components. You will notice that it has inserted a  in every module called  which contains the result of the build process.new directory target

Under your  project or sub-module, you should now have a , which is the pre-installation package of dspace /target/dspace-<version>.dir/
DSpace 1.5. It is from here that we must initialize our local copy of the application for development.

Preparing Configuration

Before we do any build work, we must prepare the DSpace configuration.

Create a <dspace> directory where you want to install DSpace on your computer (e.g.  or )C:\dspace /dspace
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Also create a  folder here, and copy the  to this config <workspace>/dspace/target/dspace-<version>.dir/config/dspace.cfg <ds
 location.pace>/config

Edit this  file to contain the correct configuration for your intended DSpace installation.dspace.cfg

The most critical things to get right are the installation path and the database path. This documentation does not cover setting up the DSpace database, 
  but you should do this before going any further. Please refer to the DSpace System Documentation for additional instructions.

The installation path you give should be:

  dspace.dir = <dspace>

where  is the absolute path of the folder where you want DSpace to be installed. Other configuration that you should ensure are set correctly are <dspace>
as follows (assuming installation on the local machine):

  # DSpace base URL.  Include port number etc., but NOT trailing slash
  dspace.url = http://localhost:8080/dspace-jspui

  # DSpace host name - should match base URL.  Do not include port number
  dspace.hostname = localhost

  # Name of the site
  dspace.name = DSpace 1.5

Running Ant to Install DSpace

Now, we want to create a fresh installation of DSpace. This will create our database properly, and setup the <dspace> installation location. (You only need 
to do a "fresh install" once! So, you can skip this, if you've already done it)

In your  project/sub-module, locate . This is the Ant build file for DSpace.dspace /target/dspace-<version>.dir/build.xml
Right click the  file and select build.xml Run As -> Ant Build ...
Targets Tag: uncheck "compile" and check "fresh_install"
Main Tag: In the Arguments box, insert , where <dspace> is the full path of the folder where you -Dconfig=<dspace>/config/dspace.cfg
are installing DSpace.
Hit "Run" at the bottom of the page.

If you are looking at the Console view in Eclipse, you will see it installing DSpace, and creating and preparing the database.

Configure Eclipse Tomcat Integration

You only need to follow these steps if you want to integrate your DSpace projects with the Eclipse Tomcat Plugin.

Modifying the Maven Tasks in Eclipse

In order to ensure the Tomcat Plugin can run off of the web applications within the various  directories, we need to tell all of our Maven build /target/
tasks where our  configuration file is.dspace.cfg

Go back into each of the Maven build tasks you defined in the  section above, and add the following parameter:Defining Maven Tasks in Eclipse

   dspace.config = <dspace>/config/dspace.cfg

where <dspace> is the full path of where you installed DSpace.

Note: You do not need to make this change for the  task, as it doesn't need to know where this configuration file resides.DSpace Clean

Finally, reassemble all of DSpace by rerunning your  task.DSpace Assemble

Configuring Tomcat Projects

If you would like the ability to perform live  through the Eclipse Tomcat Plugin, you will need to setup the appropriate DSpace web interface debugging
projects as .Tomcat Projects

The project properties that you would need to modify are available by Right Clicking on the project name and
selecting .Properties -> Tomcat

For One-Big-Project Approach
Make sure to check the option "Is a Tomcat Project"
Set the context name to be similar to:  (this context path can be anything and is what you want Tomcat to use in the URL)dspace-1_5
You will have to choose which interface you want to debug, since only one interface is supported at a time.

https://wiki.lyrasis.org/display/DSPACE/DSpaceResources#DSpaceResources-DSpace_System_Documentation
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If debugging , set the web application root to be: dspace-jspui /dspace/target/dspace-<version>-build.dir
/webapps/jspui
If debugging , set the web application root to be: dspace-oai /dspace/target/dspace-<version>-build.dir
/webapps/oai
If debugging , set the web application root to be: dspace-xmlui /dspace/target/dspace-<version>-build.dir
/webapps/xmlui
If debugging , set the web application root to be: dspace-lni /dspace/target/dspace-<version>-build.dir
/webapps/lni

For multi-project approaches, you can debug multiple interfaces at once. Therefore, you can set up each of the below projects to run under 
separate Tomcat contexts:

dspace-jspui
Make sure to check the option "Is a Tomcat Project"
Set the context name to be similar to: dspace-jspui
Set the web application root to be: /target/dspace-jspui-<version>

dspace-oai
Make sure to check the option "Is a Tomcat Project"
Set the context name to be similar to: dspace-oai
Set the web application root to be: /target/dspace-oai-<version>

dspace-xmlui
Make sure to check the option "Is a Tomcat Project"
Set the context name to be similar to: dspace-xmlui
Set the web application root to be: /dspace-xmlui-webapp/target/dspace-xmlui-webapp-<version>

dspace-lni
Make sure to check the option "Is a Tomcat Project"
Set the context name to be similar to: dspace-lni
Set the web application root to be: /dspace-lni-webapp/target/dspace-lni-webapp-<version>

Viewing the applications in a web browser

With the stages above complete you can now start tomcat and view the DSpace applications in a web browser.

(Re)start the Tomcat web server through the Eclipse interface. This is done by clicking the right-most of the three tomcat buttons that are in the Eclipse 
toolbar courtesy of the SysDeo plugin. (In normal operation, you can restart the context without restarting tomcat, which can be done by right clicking on 
the project name and selecting Tomcat project -> Reload this context; furthermore, Eclipse will regularly auto-deploy the context while you are making 
changes). You can see the results of these actions reflected in the Console View if you have it open.

You should now find the web interface deployed; try one of the following URLs to see if they are working:

http://localhost:8080/dspace-jspui (JSP-UI)

http://localhost:8080/dspace-oai/request?verb=Identify (OAI-PMH)

http://localhost:8080/dspace-xmlui (XML-UI)

Viewing the Database in Eclipse
Go to the Database Explorer View and select " " from the right.New Connection
Use the following details to create a new database connection: . Enter the database name ; The JDBC driver: Generic JDBC -> 1.0 dspace-svn org.

; The location of the driver will be the postgres JAR file, in ; The connection URL should be as specified in your postgresql.Driver dspace-svn/lib
dspace.cfg: . To check that this is working hit " ". Once it is hit " ".jdbc:postgresql://localhost:5432/dspace-svn Test Connection Finish
Browse your database using the Database Explorer View:  will show Connections -> dspace-svn -> dspace-svn -> Schemas -> public -> Tables
you a list of the tables that Ant created during install, for example

There are lots of things you can do with the database connection, including issuing queries, so it's worth playing around with.

So what use is this really?
Well, aside from the obvious benefits of having everything compiled in the background while you are working, and having everything, including database 
browsing and querying integrated into your development environment, consider the following exercises:

DSpace 1.4.2

Open the file dspace-svn/src/org/dspace/app/webui/servlet/DSpaceServlet.java
Scroll down to the method:

 private void processRequest(HttpServletRequest request,
            HttpServletResponse response) throws ServletException, IOException

and find the line of code which reads:

http://localhost:8080/dspace-jspui
http://localhost:8080/dspace-oai/request?verb=Identify
http://localhost:8080/dspace-xmlui


  // Are we resuming a previous request that was interrupted for
  // authentication?
  request = Authenticate.getRealRequest(request);

around line 136.

Once you have found this line, right click in the margin on the left side of the line numbers, and select " ". A blue circle, with a Toggle Breakpoint
tick in it, will appear.
Go to your web browser, and select any link appart from the home page. For example, browse by title.
Did you see what happened? Eclipse should have intervened in your web browsing, offering to open the debug mode for the application. If you 
agree to the request, you are flipped back into Eclipse in the Debug Perspective. You should find that the file DSpaceServlet is open, and 
execution of the code has ceased at the line where we set the breakpoint. From this point you can step through the code, line-by-line if you like, 
and see the state of all the variables and your position in the stack at whatever point you like. Now that's useful!

DSpace 1.5

Open the file <workspace>/dspace-api/src/main/java/org/dspace/browse/Browse.java
Scroll down to the method:

public static BrowseInfo getItemsByTitle(BrowseScope scope)
            throws SQLException
{
        scope.setBrowseType(ITEMS_BY_TITLE_BROWSE);
        scope.setAscending(true);
        scope.setSortByTitle(null);

        return doBrowse(scope);
}

around line 165 of Browse.java

Once you have found this line, right click in the margin on the left side of the line numbers, and select " ". A blue circle, with a Toggle Breakpoint
tick in it, will appear.
Go to your web browser and select the "Browse by Title" page (it doesn't matter if you have any items in your archive or not)
Did you see what happened? Eclipse should have intervened in your web browsing, offering to open the debug mode for the application. If you 
agree to the request, you are flipped back into Eclipse in the Debug Perspective. You should find that the file DSpaceServlet is open, and 
execution of the code has ceased at the line where we set the breakpoint. From this point you can step through the code, line-by-line if you like, 
and see the state of all the variables and your position in the stack at whatever point you like. Now that's useful!

This example is particularly cool because the code with the breakpoint in it is in a separate project to the JSPUI, which is the application you actually 
loaded through the UI. By including the classes produced by the dspace-api project into the library of the dspace-jspui project, it means that we can debug 
across both projects simultaneously, as well as the same piece of API code accessed from multiple interfaces (e.g. OAI).

More tips and tricks

There are plenty of opportunities for this sort of integration to be useful, and I would encourage people to add their tips and tricks to this page.
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